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Software Drivers Training
Instructions in the basics of the software.

Students can do really terrific data analysis by hand. But in this book, we assume they use 
software for graphing and calculation.

These pages contain instructions in some of the basics of the two programs we used when we 
were designing this book: Fathom and Logger Pro. Both of these packages are easy to use. In 
addition, they support students making their own discoveries, constructing their own for-
mulas, and setting up displays the way they want. They’re powerful, too, in their attention to 
how people learn through data. And they don’t just do it all for you; you still have to think.

Both programs are also visual, not just in their graphs but also in the interface—how users 
interact with the program. Learning these programs is not just learning commands; you learn 
gestures as well, dragging and dropping screen objects to accomplish what you want to do. 

This makes it easy to do many things. But it makes it hard to write about.

Therefore, in the instructions for labs, we have generally avoided including instructions about 
how to drive the computer. The positive side of this decision is clear: you can use the lab with 
any future version of these or any other software packages. Even more important, the instruc-
tions are about data analysis and physics, not about the computer. 

Whence this section of the book. We have made brief 
instructions for most of the basic computer skills students 
will need, in a bilingual format (Fathom and Logger Pro; 
the text is English-only in this edition, alas). We suggest 
that you copy them for students to help them remember 
skills that you have demonstrated, especially if they have 
not seen the software in a while. Experiment!

What are these skills?

Making new columns� and entering data into columns 
by hand. 

Making formulas to calculate values in a column.

Making scatter plots.

Rescaling axes.

Plotting functions on scatter plots.

Making variable parameters.

Plotting straight lines on scatter plots.

In addition, if you use Fathom, you will want to know 
how to use residual plots and units effectively, and if 
you use Logger Pro, you will want to know how to use 
its automatic curve fitting. For both programs, there are 
countless tips and tricks that might fit—or not—with 
each individual’s computational style. Many of these 
would just clutter a book like this.

Finally, software always changes. 

So visit http://www.denofinquiry.com to find additional 
instructions, tip reports, notes on the effect of software 
updates, and so forth.

�	 You can also think of columns as variables. Fathom calls them attributes. 
There are good (but relatively esoteric) reasons for all this confusion 
over what to call them.

�

�

�

�

�

�

�

So how will students learn to use the software? Here are 
some things we have observed:

Students learn very quickly from each other, but still 
need guidance.

A ten-second demo by the teacher can save many min-
utes of step-by-step instructions.

It’s hard for many students to learn computer skills 
by reading about them. But they can use brief printed 
materials effectively as reminders.

�

�

�
This is the icon for 
Logger Pro

This is the icon for 
Fathom. 
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Data Entry in Fathom

In Fathom, you enter data into a case table, which resem-
bles a spreadsheet table.

Start up Fathom and open a new Fathom document. 

Drag a case table off the shelf and put it in your docu-
ment.

Click where it says <new> to make a new column (or 
variable). Enter a name for the column (width in the 
example). Press tab, enter, or return to finish mak-
ing that new column.

Do the same to make another new column, height (or 
whatever variable name you need).

Enter data into the appropriate cells. You can enter 
units right with the data. After you have entered the 
first case (the first row), Fathom remembers what 
units you are using.

✧

✧

✧

✧

✧

Calculated Columns in Fathom
First you make the new column, then you give it a for-
mula.

To make a new column (a new variable or attribute) 
do one of the following:

Make a new column by clicking on a <new> col-
umn heading in the case table, or

Choose New Attribute from a case table’s context 
menu.

Give the new column a name. Press enter or return.

Open the formula editor for the column by doing one 
of the following

Context-click (see the gray box below) on the 
name of the new attribute and choose Edit Formula 
from the context menu.

Double-click the cell in the “formula row” for that 
attribute. (Be sure Show Formulas is on; it’s in the 
table’s context menu.)

Enter the formula for the column. You can enter vari-
ables and functions by typing or by double-clicking 
them in the “browser” pane.

Close the formula editor by clicking OK. 
 

✧

�

�

✧

✧

�

�

✧

✧

Context Menus
To get a “context menu,” point at an object and right-
click (Windows) or control-click (Macintosh).
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Data Entry in Logger Pro
Logger Pro has a data table visible by default, with two 
columns, X and Y. You need to change their names and 
give them units if necessary.

Double-click the X at the top of the column. The 
Column Options dialog appears. There, in the Column 
Definition panel (shown), you can edit the name and 
the short name of the variable, and enter its units. 
Press Done when you have it the way you want.

Do the same for the Y column. In the illustration, we 
have changed Y to mass and given it units of grams (g)

For additional columns, choose New Manual Column 
from the Data menu.

Enter the data in the table cells. Do not include the 
units in the cells themselves.

Note: If you have an interface and probes attached to 
your computer, Logger Pro may detect the probes and 
you will not have the X and Y columns where you can 
enter data manually.

✧

✧

✧

✧

Calculated Columns in Logger Pro
Make the new column and formula in one handy dialog 
box.

Choose New Calculated Column… from the Data menu. 
Be sure you’re looking at the Column Definition panel.

In the dialog box, give your new column a name and 
(optionally) a short name and units.

In the Equation field, enter its formula.

Note that other column names have to be enclosed 
in quotes, and that you enter only the part of the 
equation to the right of the equals sign.

If you wish, you can choose other variables (and 
functions) from the menus.

Close the dialog box by pressing Done.

To change an existing formula, double-click the col-
umn heading.

✧

✧

✧

�

�

✧

✧
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Scatter Plots in Fathom

Here is how you make a graph:

Drag a new graph off the shelf. Put it in your docu-
ment so that it does not overlap your case table. (You 
may have to make the table smaller.) 

The graph starts out empty. You haven’t told Fathom 
what to graph. Tell Fathom what to graph by labeling 
your axes. 

Drag the name of the horizontal-axis variable (width in 
the illustration) from the column heading in the case 
table to the horizontal axis of the graph. 

The correct area will highlight when you’re there. 

Drop the name on the axis. A graph of all the widths 
appears.

Do the same with the vertical-axis variable; this creates 
a scatter plot.

✧

✧

✧

✧

Plotting Functions in Fathom:
Point at the graph and right-click (Windows) or con-
trol-click (Macintosh) with the mouse. As you hold 
the button down, a context menu appears. 

Choose Plot Function… from the graph’s context 
menu. It’s way down at the bottom. The formula editor 
appears.

Enter your function in the formula editor. Press OK or 
the enter key to plot your function. The formula edi-
tor goes away and the function appears on the graph.

If the function is not right, double-click it where it 
appears at the bottom of the graph; the formula editor 
opens. Edit the function and click OK. (If you click Ap-
ply, the function changes but the editor stays open.)

We used a variable parameter, k, in our function, 
instead of entering a constant. Use a slider to set the 
value of k; see Variable Parameters (page 24).

When in doubt, use parentheses.

✧

✧

✧

✧

✧

✧

Note: As long as the formula editor is open, you can’t 
do anything outside the editor. So sometimes when 
everything seems stuck, all you have to do is close the 
formula editor.
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Scatter Plots in Logger Pro
In Logger Pro, you have a graph by default; the problem 
is making sure things get plotted the right way.

Your data should be in two columns in the table. By 
default, Logger Pro makes a line graph of the data with 
the first variable (the one that was originally x) on the 
horizontal axis.

If the variables are on the right axes, fine. 

If not, point at the name of the variable on the hori-
zontal axis and hold the mouse button down. A menu 
appears; select the name of the variable you want 
there. Do the same for the vertical axis.

Now you need to get rid of the dot-to-dot lines and make 
the points bigger so you can see them. 

Double-click the graph itself; a dialog box appears (see 
the figure). In the Graph Options panel (shown), select 
Point Protectors and deselect Connect Points. When 
you close this dialog, your graph will be the way you 
need it.

✧

✧

Plotting Functions in Logger Pro
Select the graph, then press the Curve Fit button  in 
the tool bar. The Curve Fit dialog appears, where you 
can select a function from the list.

Select a function (in the illustration we chose mx + b).

Up at the top, choose the Manual option. 

The dialog shows a thumbnail of the graph, and the 
values of whatever parameters (in this case, m and b) you 
need for your function. 

Type in the values you want for the parameters, or 
change them using the up-down arrow buttons . 
The curve will change in the thumbnail graph. 

When the curve looks pretty good, press OK to leave 
that dialog. Logger Pro puts the function on the main 
graph, with a “callout” box. (You can refine the pa-
rameter values in version 3.4 or later.)

If you don’t see the function you want in the list, click 
the Define Function… button. Enter whatever you 
want. Its parameters appear on the right, in the panel 
under Coefficient Values.  

Need more details? See page 26.

✧

✧

✧

✧

✧

✧
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Variable Parameters in Fathom

Drag a new slider off the shelf. Find an empty area to 
put it in.

It’s named V1 already. Edit that name to give it a 
new name, such as K. Press enter or return to tell 
Fathom you’re done naming it.

Change the value of the parameter by typing or by 
sliding the pointer.

You can add units to a slider-parameter. Use ^ (shift-
6) for exponentiation.

The number line is an axis, just like on a graph. If you 
run out of numbers, or need finer control, just rescale 
the axis (see the section at right).

Use the slider’s name in any formula; Fathom will 
update the results of the formula as you change the 
value.

For example, to include a new parameter in a func-
tion, double-click the function where it appears at the 
bottom of a graph and edit the function to include the 
parameter name (e.g., change H = 1/W to H = K/W). 

If you’re using slider-parameters in a function, you can 
create the sliders before or after you create the function. 
Fathom figures it out.

However, if you do the function first, the message you get 
may be misleading. Frequently, Fathom gives a units in-
compatible error when it really means Name not recognized.

✧

✧

✧

✧

✧

✧

✧

Rescaling Axes in Fathom
To autoscale axes and show all the data, just re-choose 
Scatter Plot from the menu in the corner of the graph. 
Alternatively, choose Rescale Graph Axes from the graph’s 
context menu.

But what if you want to scale the axes some other way?

Move the cursor—without clicking—over the numbers of 
an axis. You’ll notice that the cursor changes shape. It’s a 
hand that “points” in different directions. 

With the cursor in each of these shapes, try “grabbing” 
the axis numbers and dragging parallel to the axis. The 
graph will rescale.

The basic rule is, if you need more values on the axis (i.e., 
zoom out), go to the end where you need the values, grab 
a number, and drag it to the middle. If you need fewer 
values on the axis (i.e., zoom in), grab a number near the 
end and shove it off the end of the axis to get rid of it. If 
you just want to change where the axis is centered (but 
have it view the same range of numbers) drag the axis 
numbers from the middle.

You can also just type in the axis bounds you want. 
Double-click the graph or slider to get that object’s inspec-
tor. There you can type in 
values for the minimum and 
maximum.

Zoom-in shortcut: hold down 
the option key (control 
in Windows) and point at 
the axis numbers. The cursor 
changes to a magnifying glass. 
Click among the numbers to 
make the axis zoom in to that 
place on the axis.
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Variable Parameters in Logger Pro
For this, you need at least Version 3.4.

Briefly, you can control the values of parameters that ap-
pear in the function “callouts” by clicking on them and 
then using the arrow keys.

In the illustration, look for the “»” indicator next to the 
value of J. If you click on the name of a parameter, that 
double-chevron (») appears, which indicates that you can 
adjust its value using the up/down arrow keys. If you click 
the value, you can edit it in place (the illustration shows 
that we can edit the current value of J, which is 80).

If you double-click this “model” box, you get the Model-
ing options dialog, in which you can specify the increment, 
which is how much the value of each parameter changes 
with each press of an arrow key.

You can also (invisibly) change the increment by pressing 
the left and right arrow keys when the double-chevron is 
visible.

Rescaling Axes in Logger Pro
To autoscale a graph, press the autoscale button 
on the tool bar.

To zoom in,  
press the plus-magnifier.

To zoom out,  
press the minus-magnifier.

Often, pressing  and then  gets you a reasonable 
window.

If you don’t want to autoscale, you have several choices:

Click on the number at either end of the axis (or click 
where the number would be if there was one!). Type in 
a new number to change the limiting value there.

Point near an axis, between the axis and the numbers. 
A springy cursor appears. Drag that cursor to change 
the scale.

Double-click the graph to bring up the Graph Options 
dialog. Bring up the Axes Options panel. There you can 
control how each axis behaves.

�

�

�
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Models and Parameters in Logger Pro
Here is additional information about some of the trickier 
aspects of plotting functions on your Logger Pro scatter plots 
in version 3.4 or later.

Defining Columns
When you define a new column (Data>New Manual Column 
or Data>New Computed Column), give your variable a good 
name and a good short name. It’s best if the short name is 
one letter long.

Defining Your Own Function
In this book, you will often need to define your own 
function. Press  for the Curve Fit dialog, then press the 
Define Function… button.

Then type the function into the box. Here you should be 
aware of a few things:

The variable in your function must be the short name 
of the column on the horizontal axis. 

Any other letters you use become parameters.

Use ^ to express powers, as in y = Ax^2 + C. (Here, A 
and C are parameters.)

You can use functions, with their arguments enclosed 
in parentheses. Common ones are sin( ), cos( ), log( ), 
sqrt( ), ln( ), and exp( ).

Once you have defined a function, you can use it mul-
tiple times in the same graph. Each curve has its own 
values for the parameters.

�

�

�

�

�

User Parameters
You may see references to “user parameters.” Choose User 
Parameters… from the Data menu to see them and make 
new ones. Logger Pro comes with one already defined: pi.

You can most easily control the value of user parameters 
by choosing Parameter Control from the Insert menu. This 
makes a widget that looks like a meter, but has a control.

User parameters can be useful, but they are not the same 
as the parameters in models (such as the A in y = Ax^2). In 
particular:

You can’t use a user parameter as part of a function 
definition (e.g., as a coefficient, like a regular param-
eter). If you use the name in a function definition, you 
get a completely new parameter—with the same name 
but a different value. This can be confusing.

You can use parameters in formulas in calculated 
columns. Then, changing the value of the parameter 
changes the data.

Therefore, consider using user parameters only for actual 
constants (such as pi), or parameters that affect the data 
(such as the diameter of a washer), and avoid them for 
parameters that affect models. 

Comparison with Fathom
Fathom’s sliders, in contrast, are true global values. With-
in a document, if you have a slider named K, its value is 
the same wherever you use it: in a calculated column, in 
a formula for a function, wherever—and changing the 
slider will affect everything. That’s a good thing.

What you cannot do in Fathom, however, is use multiple 
functions having the same parameter but different values. 
If you want to show models with minimum and maxi-
mum plausible values for g, you need to make extra slid-
ers for gmin and gmax. In Logger Pro, just make another 
function.

�

�


